Multiple Area OSPF Dengan Virtual-Link

Pada tutorial konfigurasi Uji Koneksi Multi Area OSPF Dengan Cisco Packet Tracer ini, konfigurasi default untuk area 0 (area zero) bertindak sebagai penghubung antar area-area lain (seperti area 1 dan area 2). Hal ini terlihat area 0 berada diantara koneksi area 1 dan area2. Dan sebenarnya konsep multiple area OSPF mengharuskan setiap area harus terkomunikasi langsung dengan backbone area atau area 0. Untuk itu area-area tersebut  berada diantara area zero.

Kali kita akan melakukan konfigurasi multiple area OSPF dengan virtual-link. Virtual-link ini akan menghubung antar router-router ABR yang mengkomunikasikan area yang tidak terhubung secara langsung dengan area 0. Seperti gambar dibawah ini.

Terlihat pada gambar topologi jaringan OSPF diatas, terdapat beberapa area diantaranya area 0, area 1 dan area 2. Implementasi area OSPF mengharuskan tiap-tiap area terhubung ke area 0, tetapi pada topologi diatas area 2 tidak terhubung langsung ke area 0. Untuk kasus ini digunakan virtual-link untuk menghubungkan area 2 kepada area 0 agar implementasi area OSPF dapat terbentuk. untuk lebih mengerti, ada baiknya kita konfigurasi router-router untuk membangun komunikasi antar interface.

#R1

!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
router ospf 100
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
!
ip classless
!

#R2

!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 170.100.50.2 255.255.255.0
duplex auto
speed auto
!
router ospf 100
log-adjacency-changes
area 1 virtual-link 3.3.3.3
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 170.100.50.0 0.0.0.255 area 1
!
ip classless
!

#R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 170.100.50.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.200.50.3 255.255.255.0
duplex auto
speed auto
!
router ospf 100
log-adjacency-changes
area 1 virtual-link 2.2.2.2
network 3.3.3.3 0.0.0.0 area 1
network 170.100.50.0 0.0.0.255 area 1
network 192.200.50.0 0.0.0.255 area 2
!
ip classless
!

#R4

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 192.200.50.4 255.255.255.0
duplex auto
speed auto
!
router ospf 100
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 2
network 192.200.50.0 0.0.0.255 area 2
!
ip classless
!

Dibawah ini ditampilan beberapa tabel routing masing-masing router untuk menganalisis informasi-informasi dalam tabel RIB router OSPF. Analisis tabel routing dalam router-router OSPF dengan memperhatikan informasi tabel routing router #R4 apakah memiliki informasi jalur menuju ke router #R1.

Tabel Routing #R1

Tabel Routing #R2

Tabel Routing #R4

Pada tabel RIB #R4 hanya menampilkan informasi routing rute 4.4.4.4 dan 192.200.50.0/24. Informasi-infomarsi tentang router-router lainnya seperti #R1,#R2 dan #R3 tidak ditampilkan di tabel RIB #R4. Jalur untuk mencapai router #R1 tidak ada artinya kita tidak dapat mengirim paket kepada jaringan yang ada di router #R1. Untuk informasi tabel routing router #R4 jelas tidak menampilkan informasi suatu jalur menuju router #R1. Hal ini diakibatkan kesalahan dalam menentukan sekaligus menetapkan area-area OSPF yang terhubung kepada area zero. Penggunaan konsep area OSPF sendiri dimana area-area yang terbentuk harus terhubung ke area zero sehingga informasi-informasi area lainnya dapat disebar melalui area backbone tersebut.

Untuk itu digunakan virtual-link multiple area routing OSPF. Implementasi virtual-link ini digunakan untuk menghubungkan area ospf yang tidak terhubung langsung ke area 0. Seperti gambar diatas area 1 bertindak sebagai penghubung area 0 dan area 2. Area 2 tidak terhubung lansung kepada area 0, sehingga router #R4 tidak memiliki informasi jaringan pada router #R1. Kita perlu melakukan konfigurasi untuk menghubungkan area 2 dengan area 0 melalui virtual-link pada router ABR OSPF. Dalam kasus ini virtual-link akan dilakukan pada router ABR #R2 dan #R3, karena kedua router tersebut yang memiliki informasi area 0, area 1 dan area 2. Konfigurasi virtual-link multiple area OSPF seperti dibawah:

Area < area ospf> virtual-link <IP_address_router_ID>

Gambar dibawah ini akan memberikan contoh penerapan konfigurasi virtual-link OSPF.

Seperti ditunjukkan pada gambar konfigurasi virtual-link OSPF, area 1 virtual-link 3.3.3.3. area 1 digunakan untuk mengkomunikasikan area 2 kepada area 0, IP address 3.3.3.3 sebagai alamat router-id router ABR #R2. Sebaliknya konfigurasi pada router #R2 demikian juga, hanya mengganti router-id yang merujuk ke #R3. Hasil adjacency OSPF diatas menampilkan telah terbentuk hubungan dengan IP address 3.3.3.3 pada OSPF_VL1. Ini merupakan adjacency virtual-link yang baru saja kita konfigurasi.

Selanjutnya kita coba periksa tabel RIB #R4 jika telah memiliki informasi jalur menuju jaringan router #R1. Seperti tabel RIB #R4 dibawah.

Tabel Routing #R4

Tabel routing #R4 gambar diatas menunjukkan informasi 1.1.1.1 yang merupakan informasi route_id #R1, artinya kita sudah memiliki informasi router #R1 dan jalur menuju kesana. Dengan virtual-link OSPF, kita dapat menghubungkan area-area lain yang tidak terhubung langsung ke area 0 sehingga informasi routing dapat dipropagasi.

Dibawah ini disertakan beberapa informasi tabel routing tentang informasi virtual-link OSPF untuk kasus kali ini.

Tabel Routing #R2

Tabel Routing #R3

1 comment
  1. ululf01 said:

    Makasih gan penjelasan dengan konfigurasinya pluss gambarnya

    moga ilmunya bermanfaat dan bertambah

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: