Konfigurasi AS-SET Aggregate Routing BGP

Mekanisme aggregasi adalah suatu cara mengumpulkan beberapa rute menjadi rute yang lebih kecil dan lebih umum diteruskan kepada jalur dituju. Aggregasi akan mengurangi beban rute dalam tabel routing suatu router yang menampung dan menyimpan rute-rute dari peer dan neighbor. AS-SET salah satu tipe attribute AS-PATH dipergunakan untuk update prefix tiap-tiap AS dalam topologi jaringan BGP. AS-SET akan mengumpulkan jalur-jalur yang dilalui oleh AS untuk mencapai AS lainnya.

Konfigurasi ini akan memberikan sedikit pemahaman tentang aggregate, AS-SET, jaringan BGP. Dibawah ini topologi jaringan BGP yang saya gunakan …

#Router1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 20.20.20.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 400
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 neighbor 20.20.20.2 remote-as 300
 no auto-summary
!

#Router2

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 20.20.20.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 30.30.30.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 40.40.40.1 255.255.255.252
 shutdown
 duplex auto
 speed auto
!
router bgp 300
 no synchronization
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 aggregate-address 192.150.0.0 255.255.0.0 as-set summary-only
 neighbor 20.20.20.1 remote-as 400
 neighbor 30.30.30.2 remote-as 100
 no auto-summary
!

#Router3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 30.30.30.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 50.50.50.1 255.255.255.252
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 30.30.30.1 remote-as 300
 neighbor 50.50.50.2 remote-as 10
 no auto-summary
!
#Router4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 40.40.40.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 60.60.60.1 255.255.255.252
 duplex auto
 speed auto
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 neighbor 40.40.40.1 remote-as 300
 neighbor 60.60.60.2 remote-as 20
 no auto-summary
!
#Router5
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Loopback1
 ip address 192.150.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.150.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.150.3.1 255.255.255.0
!
interface Loopback4
 ip address 192.150.4.1 255.255.255.0
!
interface Loopback5
 ip address 192.150.5.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 50.50.50.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.5 mask 255.255.255.255
 network 192.150.1.0
 network 192.150.2.0
 network 192.150.3.0
 network 192.150.4.0
 network 192.150.5.0
 neighbor 50.50.50.1 remote-as 100
 no auto-summary
!
#Router6
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Loopback6
 ip address 192.150.6.1 255.255.255.0
!
interface Loopback7
 ip address 192.150.7.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 60.60.60.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router bgp 20
 no synchronization
 bgp log-neighbor-changes
 network 6.6.6.6 mask 255.255.255.255
 network 192.150.6.0
 network 192.150.7.0
 neighbor 60.60.60.1 remote-as 200
 no auto-summary
!

Periksa hasil konfigurasi, pergunakan perintah show ip bgp

#Router2

#Router1

Proses diatas perlu diterapkan untuk topologi jaringan dengan rute yang kompleks seperti ISP. Untuk itu dibutuhkan pemahaman terhadap rute-rute jaringan yang tersimpan dalam tabel routing suatu router.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: