IPv6 Manual Tunnels

Terdapat beberapa metode transisi antara IPv6 dan IPv4 maupun sebaliknya. Kali ini saya memakai metode transisi secara manual yaitu “Manual Tunnels”. Dengan mekanisme transisi ini jaringan lokal IPv6 dapat berkomunikasi dengan jaringan IPv6 lainnya melalui jaringan IPv4 sebagai jalur komunikasi, dengan syarat router sebagai gateway IPv6 telah support/mendukung komunikasi dan konfigurasi IPv6. Antara kedua jaringan IPv6 akan membentuk sebuah tunnel atau jalur khusus yang akan membawa paket IPv6 melalui jaringan IPv4.


Mekanisme kali ini saya memakai topologi jaringan seperti yang digambarkan diatas. Terdapat tiga buah rou

ter akan melakukan komunikasi antar kedua jaringan IPv6 (Router1 dan Router3) melalui jaringan IPv4 (Router 4). Untuk lebih jelasnya saya akan memberikan settingan pada masing-masing interface router tersebut.

Jaringan IPv4 saya pergunakan routing protokol EIGRP untuk komunikasi antara jaringan IPv4 pada Router 2. Terlebih dulu coba setting/konfigurasi R2:

#Router2

interface FastEthernet1/0

ip address 10.10.10.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/1

ip address 10.20.20.5 255.255.255.0

duplex auto

speed auto

!

router eigrp 2

network 10.0.0.0

no auto-summary

!

Kemudian lakukan konfigurasi pada Router 1 dan Router 3 yang running IPv6. Berikut konfigurasi kedua router:

#Router1

ipv6 unicast-routing

!

interface Tunnel0

no ip address

ipv6 address 2001:13::1/64

ipv6 rip GIAT enable

tunnel source FastEthernet1/0

tunnel destination 10.20.20.3

tunnel mode ipv6ip

!

interface Loopback0

no ip address

ipv6 address 2001:1::1/64

ipv6 rip GIAT enable

!

interface FastEthernet1/0

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

router eigrp 2

network 10.0.0.0

no auto-summary

!

ipv6 router rip GIAT

!

#Router3

ipv6 unicast-routing

!

interface Tunnel0

no ip address

ipv6 address 2001:13::3/64

ipv6 rip GIAT enable

tunnel source FastEthernet1/0

tunnel destination 10.10.10.1

tunnel mode ipv6ip

!

interface Loopback0

no ip address

ipv6 address 2001:3::3/64

ipv6 rip GIAT enable

!

interface FastEthernet1/0

ip address 10.20.20.3 255.255.255.0

duplex auto

speed auto

!

router eigrp 2

network 10.0.0.0

no auto-summary

!

ipv6 router rip GIAT

!

Setelah konfigurasi dilakukan pada ketiga router langkah selanjutnya yaitu memeriksa apakah R1 dapat berkomunikasi dengan R3.

Juga, kita dapat melihat tabel routing IPv6 pada Router 1 dan Router 3 apakah telah mencatat informasi IPv6 interface nya atau tidak dengan cara mengetik show ipv6 route, seperti dibawah ini:

Semoga tutorial ini memberikan masukan serta pembelajaran bagi yang ingin memperdalam pengetahuan te

ntang IPv6.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: