Redistribute Protocol Routing pada BGP (Border Gateway Protocol)

Routing BGP  berfungsi untuk mengkoneksikan antara network – network address  yang berbeda AS(Autonomous System) nya sehingga dapat terkoneksi. Protocol – protocol routing lainnya pada routing IGP(Internal Gateway Protocol) dapat dihubungkan kedalam routing BGP dalam hal ini routing IBGP yang akan menghandle routing – routing pada suatu AS. Routing IGP yang dimaksut diatas antara lain RIP, OSPF, IGRP, dan EIGRP maupun routing protocol lainnya. Misalnya protocol routing static, default routing, IS-IS, dan juga routing EGP yang ada. Tujuan utama redistribute routing pada BGP adalah untuk memperkenal routing protocol non-BGP ke routing BGP itu sendiri.

Untuk lebih jelasnya saya akan memberikan salah satu contoh mengenai redistribute routing pada BGP sekaligus  dengan konfigurasi masing – masing router sehingga dapat mengkomunikasikan protocol non-BGP ke routing BGP agar dapat lebih mudah dimengerti. Pada contoh ini saya akan mengambil protocol EIGRP agar dapat dibaca oleh routing BGP. Perhatikan gambar dibawah ini.

Gambar diatas menjelaskan bahwa router C ingin mengenalkan network address 172.16.2.0/24 dan network address 172.16.3.0/24 melalui protocol routing EIGRP. Yang mana antara router A dan router B memliki koneksi routing BGP sehingga tidak mempunyai kendala untuk berhubungan, akan tetapi pada router C memiliki routing EIGRP dan tidak dapat berhungan secara langsung ke routing BGP. Untuk itu diperlukan settingan pada router BGP agar dapat menerima routing EIGRP dari luar routing BGP maka BGP akan menggunakan redistribute protocol – protocol routing di luar BGP. Redistribute ini dilakukan agar router A dapat menerima dan mengetahui network address yang ada pada router C dengan protocol routing diluar BGP.

Router A

interface loopback 0

ip address 172.16.0.1 255.255.255.0
!

interface loopback 1

ip address 172.16.1.1 255.255.255.0

!

router bgp 1

network 172.17.1.0 mask 255.255.255.0

neighbor 172.17.1.1 remote-as 2

Router B

router eigrp 1

network 10.0.0.0

network 172.17.0.0

no auto-summary

!

router bgp 2

network 10.1.0.0 mask 255.255.255.252

network 172.17.1.0 mask 255.255.255.0

neighbor 172.17.1.2 remote-as 1

!

ip route 172.16.4.0 255.255.255.0 s2/0

Router C

interface loopback 0

ip address 172.16.2.1 255.255.255.0

!

interface loopback 1

ip address 172.16.3.1 255.255.255.0

!

router eigrp 1

network 172.16.0.0

network 10.0.0.0

no auto-summary

Masing – masing router telah dikonfigurasi sesuai dengan network – network yang ada pada tabel routing tiap router. Sebelum melakukan konfigurasi redistribute routing BGP ada baiknya melakukan pemeriksaan terhadap tabel routing maupun tabel routing BGP agar dapat mengetahui network dan metric yang ada pada suatu router BGP.  Maka untuk mengetahui hal tersebut dapat dilakukan dengan command show ip route atau show ip bgp .

rtrB#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets

C       172.17.1.0 is directly connected, Ethernet0/0

172.16.0.0/24 is subnetted, 3 subnets

S       172.16.4.0 is directly connected, Serial2/0

D       172.16.2.0 [90/1889792] via 10.1.1.2, 00:26:32, Serial2/0

D       172.16.3.0 [90/1889792] via 10.1.1.2, 00:26:32, Serial2/0

10.0.0.0/30 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Serial2/0

rtrB#show ip bgp

BGP table version is 3, local router ID is 172.17.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 10.1.1.0/30      0.0.0.0                  0         32768 i

*  172.17.1.0/24    172.17.1.2               0             0 1 i

*>                  0.0.0.0                  0         32768 i

rtrA#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

172.17.0.0/24 is subnetted, 1 subnets

C       172.17.1.0 is directly connected, FastEthernet0

172.16.0.0/24 is subnetted, 2 subnets

C       172.16.0.0 is directly connected, Loopback0

C       172.16.1.0 is directly connected, Loopback1

10.0.0.0/30 is subnetted, 1 subnets

B       10.1.1.0 [20/0] via 172.17.1.1, 00:25:38

rtrA#show ip bgp

BGP table version is 4, local router ID is 172.16.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 10.1.1.0/30      172.17.1.1               0             0 2 i

*> 172.17.1.0/24    0.0.0.0                  0         32768 i

*                   172.17.1.1               0             0 2 i

Dari hasil tabel routing pada tiap – tiap router dapat diambil kesimpulan bahwa nilai metric terbaca oleh router B adalah 1889792. Hal ini disebabkan oleh bentuk redistribute yang dipergunakan dalam hal ini tidak memiliki nilai metric. Router C menggunakan metric EIGRP sebagai penghubung ke routing BGP. Untuk itu diperlukan perubahan konfigurasi pada router A dan router B agar dapat menerima metric EIGRP tersebut.

Router A

router bgp 1

network 172.17.1.0 mask 255.255.255.0

redistribute connected

neighbor 172.17.1.1 remote-as 2

Router B

router bgp 1

network 10.1.0.0 mask 255.255.255.0

network 172.17.1.0 mask 255.255.255.0

redistribute static

redistribute eigrp 1

neighbor 172.17.1.2 remote-as 2

Sekarang saatnya melakukan ujicoba terhadap router – router diatas apakah bekerja  sesuai prinsip redistribute routing BGP.

rtrA#show ip bgp

BGP table version is 8, local router ID is 172.17.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 10.0.0.0         0.0.0.0                  0         32768 ?

*> 10.1.1.0/30      0.0.0.0                  0         32768 i

*> 172.16.0.0       0.0.0.0                  0         32768 ?

*                   172.17.1.2               0             0 1 ?

*> 172.17.0.0       172.17.1.2               0             0 1 ?

*> 172.17.1.0/24    0.0.0.0                  0         32768 i

*                   172.17.1.2               0             0 1 i

rtrB#show ip bgp

BGP table version is 19, local router ID is 172.16.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric  LocPrf   Weight  Path

*> 10.0.0.0         172.17.1.1               0             0 2 ?

*> 10.1.1.0/30      172.17.1.1             0             0 2 i

*  172.16.0.0       172.17.1.1              0             0 2 ?

*>                  0.0.0.0                  0         32768 ?

*> 172.17.0.0       0.0.0.0                  0         32768 ?

*  172.17.1.0/24    172.17.1.1            0             0 2 i

*>                  0.0.0.0                          0         32768 i

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: