Aggregate Local Route BGP

Pada pembahasan sebelum nya telah dijelaskan cara konfigurasi interval waktu pada routing BGP khususnya routing IBGP dan EBGP. Kali ini akan dibahas konfigurasi aggregate local route yakni route – route pada router bgp. Seperti pada gambar terdapat beberapa address route akan dikenalkan ke router tetangganya (Neighbor),.

Pada gambar tersebut terdapat beberapa address route yang di advertise, yakni Router B memliki network address route empat network address.  Agar dapat diminimalisasikan penggunaan network address tersebut kita memkai sistem aggreate network address yang disediakan oleh konfigurasi router BGP. Sebelum melakukan konfigurasi aggregate tersebut, terlebih dahulu lakukan konfigurasi tabel route pada kedua router BGP agar dapat saling berkomukasi dengan router tentangganya.

Router A

router bgp 1

neighbor 10.1.1.2 remote-as 2

Router B

interface loopback 0

ip address 172.16.0.1 255.255.255.0

!

interface loopback 1

ip address 172.16.1.1 255.255.255.0

!

interface loopback 2

ip address 172.16.2.1 255.255.255.0

!

interface loopback 3

ip address 172.16.3.1 255.255.255.0

!

router bgp 2

network 172.16.0.0 mask 255.255.255.0

network 172.16.1.0 mask 255.255.255.0

network 172.16.2.0 mask 255.255.255.0

network 172.16.3.0 mask 255.255.255.0

neighbor 10.1.1.1 remote-as 1

!

Keempat network address pada interface loopback yang menjadi interface simulasi dari percobaan diatas telah dikonfigurasi. Router A dan router B telah terjalin hubungan yang dapat kita lihat pada routing tabel masing – masing.

Router A

routerA#show ip bgp

BGP table version is 16, local router ID is 172.17.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0/24    10.1.1.2                 0             0 2 i

*> 172.16.1.0/24    10.1.1.2                 0             0 2 i

*> 172.16.2.0/24    10.1.1.2                 0             0 2 i

*> 172.16.3.0/24    10.1.1.2                 0             0 2 i

Router B

routerB#show ip  bgp

BGP table version is 6, local router ID is 172.16.3.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0/24    0.0.0.0                  0         32768 i

*> 172.16.1.0/24    0.0.0.0                  0         32768 i

*> 172.16.2.0/24    0.0.0.0                  0         32768 i

*> 172.16.3.0/24    0.0.0.0                  0         32768 i

Pada tabel routing diatas jelas terlihat hasil konfigurasi antara kedua router. Seperti pada penjelasan diatas tujuan konfigurasi yang kita lakukan yakni memperkenalkan network aggregate pada router tetangga. Untuk itu perhatikan konfigurasi berikut ditujukan untuk pada router B yang memiliki empat network address.

Router B

router bgp 2

network 172.16.0.0 mask 255.255.255.0

network 172.16.1.0 mask 255.255.255.0

network 172.16.2.0 mask 255.255.255.0

network 172.16.3.0 mask 255.255.255.0

aggregate-address 172.16.0.0 255.255.252.0

neighbor 10.1.1.1 remote-as 1

Konfigurasi diatas seperti dicetak warna biru terlihat aggregate network dengan subnet 255.255.252.0 mewakili keempat network address sebelumnya dengan subnet 255.255.255.0. Dengan subnet 255.255.252.0 akan lebih sederhana. Dapat telihat pada tabel routing seperti dibawah :

routerA#show ip bgp

BGP table version is 18, local router ID is 172.17.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0/24    10.1.1.2                 0             0 2 i

*> 172.16.0.0/22    10.1.1.2                               0 2 i

*> 172.16.1.0/24    10.1.1.2                 0             0 2 i

*> 172.16.2.0/24    10.1.1.2                 0             0 2 i

*> 172.16.3.0/24    10.1.1.2                 0             0 2 I

routerB#show ip bgp

BGP table version is 8, local router ID is 172.16.3.1

Status codes: s suppressed, d damped, h history, * valid, > best, i – internal

Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path

*> 172.16.0.0/24    0.0.0.0                  0         32768 i

*> 172.16.0.0/22    0.0.0.0                            32768 i

*> 172.16.1.0/24    0.0.0.0                  0         32768 i

*> 172.16.2.0/24    0.0.0.0                  0         32768 i

*> 172.16.3.0/24    0.0.0.0                  0         32768 i

Konfigurasi network aggreagate diatas merupakan salah satu atribut pada router BGP yakni Atomic – aggregate dimana konfigurasi yang dilakukan sebelumnya akan hilang/lost. Untuk itu dibutuhkan ketelitian pada konfigurasi routing tabel router BGP. Untuk kasus ini kita dapat menggunakan 16 bit mask yakni dengan subnet 255.255.0.0

Router B

router bgp 2

network 172.16.0.0 mask 255.255.255.0

network 172.16.1.0 mask 255.255.255.0

network 172.16.2.0 mask 255.255.255.0

network 172.16.3.0 mask 255.255.255.0

aggregate-address 172.16.0.0 255.255.0.0

neighbor 10.1.1.1 remote-as 1

routerA#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, * – candidate default

U – per-user static route, o – ODR

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks

B       172.16.0.0/16 [200/0] via 0.0.0.0, 00:03:01, Null0

C       172.16.0.0/24 is directly connected, Loopback1

C       172.16.1.0/24 is directly connected, Loopback2

C       172.16.2.0/24 is directly connected, Loopback3

C       172.16.3.0/24 is directly connected, Loopback4

10.0.0.0/30 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Serial0

Terlihat hasil pada tabel routing yang tadinya  hilang telah dikonfigurasi ulang untuk mendapat tabel routing lengkap. Apabila masih kurang jelas atau mengerti boleh ditanyakan pada yang bersangkutan, seperti pepatah mengatakan “malu bertanya sesat dijalan” 🙂

1 comment
  1. irfan said:

    saya mau tanya kalo suatu saat salah satu server BGP mati dan biar cepat pindah routing ke BGP satu lagi gimana ya? trus kalo mindahin routing secara manual bisa gak en boleh tau caranya kalo ada masukan.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: